Back
Maintenance

Node 1 Upgrade

Completed 2 Oct at 06:30pm CEST.

Website Hosting Paste Database 1
Completed

Maintenance completed

Posted 2 Oct at 06:30pm CEST.
Started

We are upgrading our systems to provide better performance and security.

Posted 2 Oct at 04:00pm CEST.