Back
Maintenance

Security Breach Fix & New Server Migration

Completed 31 Jul at 11:59pm CEST.

Website Hosting Paste Database 1 Java Edition Lobby Survival
Completed

Maintenance completed

Posted 31 Jul at 11:59pm CEST.
Started

We found a security problem, no data was compromised, but a miner virus was inserted. Currently all services will be offline to avoid further inconveniences.
To resolve this quickly we decided to migrate everything to a new, stronger and faster server. We apologize for the inconvenience and for the umpteenth resending of the opening of the Minecraft server.

Posted 20 Jul at 08:00pm CEST.